Broken test

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Broken test

J. Mark Owens
I cloned the latest version of Accumulo a couple of hours ago and
attempted to build it along with running the standard test suite, i.e.,
mvn clean package -Passemble.  The build failed due to an error in the
TableLoadBalancerTest class:

Failed tests:
   TableLoadBalancerTest.test:188 expected:<15> but was:<0>

I performed a git checkout of commit
3c55eed2198afc90d6c1230783fcdd64e4c7e47d and ran the tests successfully.
But the next commit, 4879f52f0334ca1c52b613d297cd3c7fd4c19afa, failed.  
Anyone willing to verify this is not just some glitch with my setup?

thanks
mark

Reply | Threaded
Open this post in threaded view
|

Re: Broken test

Mike Walch-2
I am seeing the same thing. TravisCI runs for every commit to master and
marks if the build passed or failed below:

https://github.com/apache/accumulo/commits/master

It looks like Keith might have a fix.

Feb 7, 2018 at 4:13 PM, J. Mark Owens <[hidden email]> wrote:

> I cloned the latest version of Accumulo a couple of hours ago and
> attempted to build it along with running the standard test suite, i.e., mvn
> clean package -Passemble.  The build failed due to an error in the
> TableLoadBalancerTest class:
>
> Failed tests:
>   TableLoadBalancerTest.test:188 expected:<15> but was:<0>
>
> I performed a git checkout of commit 3c55eed2198afc90d6c1230783fcdd64e4c7e47d
> and ran the tests successfully. But the next commit,
> 4879f52f0334ca1c52b613d297cd3c7fd4c19afa, failed.  Anyone willing to
> verify this is not just some glitch with my setup?
>
> thanks
> mark
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Broken test

Keith Turner
Yeah I fixed it.   The test did not fail in 1.8 and I did not rerun
all of the test when merging to master.  I think I just ran mvn
compile in master.  Running mvn verify multiple times when merging
forward is a pain, I would prefer to let Travis catch things like
this.

On Wed, Feb 7, 2018 at 4:27 PM, Mike Walch <[hidden email]> wrote:

> I am seeing the same thing. TravisCI runs for every commit to master and
> marks if the build passed or failed below:
>
> https://github.com/apache/accumulo/commits/master
>
> It looks like Keith might have a fix.
>
> Feb 7, 2018 at 4:13 PM, J. Mark Owens <[hidden email]> wrote:
>
>> I cloned the latest version of Accumulo a couple of hours ago and
>> attempted to build it along with running the standard test suite, i.e., mvn
>> clean package -Passemble.  The build failed due to an error in the
>> TableLoadBalancerTest class:
>>
>> Failed tests:
>>   TableLoadBalancerTest.test:188 expected:<15> but was:<0>
>>
>> I performed a git checkout of commit 3c55eed2198afc90d6c1230783fcdd64e4c7e47d
>> and ran the tests successfully. But the next commit,
>> 4879f52f0334ca1c52b613d297cd3c7fd4c19afa, failed.  Anyone willing to
>> verify this is not just some glitch with my setup?
>>
>> thanks
>> mark
>>
>>