Failing Jenkins?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Failing Jenkins?

Christopher Tubbs-2
Does anybody know what's wrong with Jenkins on builds.apache.org?
Nearly all of our normal Maven jobs seem to fail, and have been failing for
nearly 2 weeks.
It could be a misconfiguration, but it seems more likely it's Jenkins. It's
definitely not test failures. It's not even getting that far.

I've already looked once. If somebody else could take a peek, I'd
appreciate it, since I don't have time to look into it this week.

https://builds.apache.org/view/A/view/Accumulo/
Reply | Threaded
Open this post in threaded view
|

Re: Failing Jenkins?

Mike Drob-4
java.io.IOException
<http://stacktrace.jenkins-ci.org/search?query=java.io.IOException>:
Cannot run program "/usr/lib/jvm/java-8-openjdk-amd64//bin/java" (in
directory "/home/jenkins/jenkins-slave/workspace/Accumulo-Master"):
error=2, No such file or directory



On Tue, Jun 13, 2017 at 7:32 PM, Christopher <[hidden email]> wrote:

> Does anybody know what's wrong with Jenkins on builds.apache.org?
> Nearly all of our normal Maven jobs seem to fail, and have been failing for
> nearly 2 weeks.
> It could be a misconfiguration, but it seems more likely it's Jenkins. It's
> definitely not test failures. It's not even getting that far.
>
> I've already looked once. If somebody else could take a peek, I'd
> appreciate it, since I don't have time to look into it this week.
>
> https://builds.apache.org/view/A/view/Accumulo/
>
Reply | Threaded
Open this post in threaded view
|

Re: Failing Jenkins?

Christopher Tubbs-2
Not sure which Java and label combination we're supposed to be using. Those
settings worked before.

On Tue, Jun 13, 2017, 20:34 Mike Drob <[hidden email]> wrote:

> java.io.IOException
> <http://stacktrace.jenkins-ci.org/search?query=java.io.IOException>:
> Cannot run program "/usr/lib/jvm/java-8-openjdk-amd64//bin/java" (in
> directory "/home/jenkins/jenkins-slave/workspace/Accumulo-Master"):
> error=2, No such file or directory
>
>
>
> On Tue, Jun 13, 2017 at 7:32 PM, Christopher <[hidden email]> wrote:
>
> > Does anybody know what's wrong with Jenkins on builds.apache.org?
> > Nearly all of our normal Maven jobs seem to fail, and have been failing
> for
> > nearly 2 weeks.
> > It could be a misconfiguration, but it seems more likely it's Jenkins.
> It's
> > definitely not test failures. It's not even getting that far.
> >
> > I've already looked once. If somebody else could take a peek, I'd
> > appreciate it, since I don't have time to look into it this week.
> >
> > https://builds.apache.org/view/A/view/Accumulo/
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Failing Jenkins?

Christopher Tubbs-2
Looks like an upgrade to Maven 3.5.0 broke the "Maven 3 (latest)" selection
in Jenkins and the "Maven (latest)" one. Switching to "Maven 3.3.9" seems
to do the trick.

On Tue, Jun 13, 2017 at 9:42 PM Christopher <[hidden email]> wrote:

> Not sure which Java and label combination we're supposed to be using.
> Those settings worked before.
>
> On Tue, Jun 13, 2017, 20:34 Mike Drob <[hidden email]> wrote:
>
>> java.io.IOException
>> <http://stacktrace.jenkins-ci.org/search?query=java.io.IOException>:
>> Cannot run program "/usr/lib/jvm/java-8-openjdk-amd64//bin/java" (in
>> directory "/home/jenkins/jenkins-slave/workspace/Accumulo-Master"):
>> error=2, No such file or directory
>>
>>
>>
>> On Tue, Jun 13, 2017 at 7:32 PM, Christopher <[hidden email]> wrote:
>>
>> > Does anybody know what's wrong with Jenkins on builds.apache.org?
>> > Nearly all of our normal Maven jobs seem to fail, and have been failing
>> for
>> > nearly 2 weeks.
>> > It could be a misconfiguration, but it seems more likely it's Jenkins.
>> It's
>> > definitely not test failures. It's not even getting that far.
>> >
>> > I've already looked once. If somebody else could take a peek, I'd
>> > appreciate it, since I don't have time to look into it this week.
>> >
>> > https://builds.apache.org/view/A/view/Accumulo/
>> >
>>
>
Reply | Threaded
Open this post in threaded view
|

Re: Failing Jenkins?

Christopher Tubbs-2
Ugh, I can't seem to get the 1.7 and 1.8 branches to execute the asciidoc
plugin without running out of permgen space (I've tried lots of different
settings for permgen size). I'm just going to move all the jenkins builds
to Java 8.

On Wed, Jun 14, 2017 at 1:52 PM Christopher <[hidden email]> wrote:

> Looks like an upgrade to Maven 3.5.0 broke the "Maven 3 (latest)"
> selection in Jenkins and the "Maven (latest)" one. Switching to "Maven
> 3.3.9" seems to do the trick.
>
> On Tue, Jun 13, 2017 at 9:42 PM Christopher <[hidden email]> wrote:
>
>> Not sure which Java and label combination we're supposed to be using.
>> Those settings worked before.
>>
>> On Tue, Jun 13, 2017, 20:34 Mike Drob <[hidden email]> wrote:
>>
>>> java.io.IOException
>>> <http://stacktrace.jenkins-ci.org/search?query=java.io.IOException>:
>>> Cannot run program "/usr/lib/jvm/java-8-openjdk-amd64//bin/java" (in
>>> directory "/home/jenkins/jenkins-slave/workspace/Accumulo-Master"):
>>> error=2, No such file or directory
>>>
>>>
>>>
>>> On Tue, Jun 13, 2017 at 7:32 PM, Christopher <[hidden email]>
>>> wrote:
>>>
>>> > Does anybody know what's wrong with Jenkins on builds.apache.org?
>>> > Nearly all of our normal Maven jobs seem to fail, and have been
>>> failing for
>>> > nearly 2 weeks.
>>> > It could be a misconfiguration, but it seems more likely it's Jenkins.
>>> It's
>>> > definitely not test failures. It's not even getting that far.
>>> >
>>> > I've already looked once. If somebody else could take a peek, I'd
>>> > appreciate it, since I don't have time to look into it this week.
>>> >
>>> > https://builds.apache.org/view/A/view/Accumulo/
>>> >
>>>
>>