InMemoryMapTest Looks For accumulo-site.xml File

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

InMemoryMapTest Looks For accumulo-site.xml File

David Medinets
I did not expect one of the tests to be looking for the site
configuration file. When compiling Accumulo for the first time, this
configuration file can't exist ... can it?

Running org.apache.accumulo.server.tabletserver.InMemoryMapTest
12/07/13 01:56:09 WARN conf.SiteConfiguration: accumulo-site.xml not
found on classpath
12/07/13 01:56:09 WARN util.NativeCodeLoader: Unable to load
native-hadoop library for your platform... using builtin-java classes
where applicable
Reply | Threaded
Open this post in threaded view
|

Re: InMemoryMapTest Looks For accumulo-site.xml File

John Vines
This is a side effect of moving the configurations into the examples I
think. The real question is are there any issues, because those are just
WARNings. Did it break the test?

John

On Thu, Jul 12, 2012 at 11:30 PM, David Medinets
<[hidden email]>wrote:

> I did not expect one of the tests to be looking for the site
> configuration file. When compiling Accumulo for the first time, this
> configuration file can't exist ... can it?
>
> Running org.apache.accumulo.server.tabletserver.InMemoryMapTest
> 12/07/13 01:56:09 WARN conf.SiteConfiguration: accumulo-site.xml not
> found on classpath
> 12/07/13 01:56:09 WARN util.NativeCodeLoader: Unable to load
> native-hadoop library for your platform... using builtin-java classes
> where applicable
>
Reply | Threaded
Open this post in threaded view
|

Re: InMemoryMapTest Looks For accumulo-site.xml File

David Medinets
The tests passed. The chance that someone has an accumulo-site.xml on
their classpath while compiling is admittedly small. It struck me as
odd that only two of the tests gave this warning. My real concern is
that the tests are passing without testing the correct situation.

On Fri, Jul 13, 2012 at 3:56 PM, John Vines <[hidden email]> wrote:

> This is a side effect of moving the configurations into the examples I
> think. The real question is are there any issues, because those are just
> WARNings. Did it break the test?
>
> John
>
> On Thu, Jul 12, 2012 at 11:30 PM, David Medinets
> <[hidden email]>wrote:
>
>> I did not expect one of the tests to be looking for the site
>> configuration file. When compiling Accumulo for the first time, this
>> configuration file can't exist ... can it?
>>
>> Running org.apache.accumulo.server.tabletserver.InMemoryMapTest
>> 12/07/13 01:56:09 WARN conf.SiteConfiguration: accumulo-site.xml not
>> found on classpath
>> 12/07/13 01:56:09 WARN util.NativeCodeLoader: Unable to load
>> native-hadoop library for your platform... using builtin-java classes
>> where applicable
>>
Reply | Threaded
Open this post in threaded view
|

Re: InMemoryMapTest Looks For accumulo-site.xml File

John Vines
In reply to this post by John Vines
InMemoryMapTest isn't really dependent on the site, as it will fall back on
defaults if not available. So I'm not concerned about that one. What was
the other test?

On Fri, Jul 13, 2012 at 4:27 PM, David Medinets <[hidden email]>wrote:

> The tests passed. The chance that someone has an accumulo-site.xml on
> their classpath while compiling is admittedly small. It struck me as
> odd that only two of the tests gave this warning. My real concern is
> that the tests are passing without testing the correct situation.
>
> On Fri, Jul 13, 2012 at 3:56 PM, John Vines <[hidden email]> wrote:
> > This is a side effect of moving the configurations into the examples I
> > think. The real question is are there any issues, because those are just
> > WARNings. Did it break the test?
> >
> > John
> >
> > On Thu, Jul 12, 2012 at 11:30 PM, David Medinets
> > <[hidden email]>wrote:
> >
> >> I did not expect one of the tests to be looking for the site
> >> configuration file. When compiling Accumulo for the first time, this
> >> configuration file can't exist ... can it?
> >>
> >> Running org.apache.accumulo.server.tabletserver.InMemoryMapTest
> >> 12/07/13 01:56:09 WARN conf.SiteConfiguration: accumulo-site.xml not
> >> found on classpath
> >> 12/07/13 01:56:09 WARN util.NativeCodeLoader: Unable to load
> >> native-hadoop library for your platform... using builtin-java classes
> >> where applicable
> >>
>
Reply | Threaded
Open this post in threaded view
|

Re: InMemoryMapTest Looks For accumulo-site.xml File

David Medinets
My apologies. I looked again and it was just the one test.

On Fri, Jul 13, 2012 at 4:32 PM, John Vines <[hidden email]> wrote:

> InMemoryMapTest isn't really dependent on the site, as it will fall back on
> defaults if not available. So I'm not concerned about that one. What was
> the other test?
>
> On Fri, Jul 13, 2012 at 4:27 PM, David Medinets <[hidden email]>wrote:
>
>> The tests passed. The chance that someone has an accumulo-site.xml on
>> their classpath while compiling is admittedly small. It struck me as
>> odd that only two of the tests gave this warning. My real concern is
>> that the tests are passing without testing the correct situation.
>>
>> On Fri, Jul 13, 2012 at 3:56 PM, John Vines <[hidden email]> wrote:
>> > This is a side effect of moving the configurations into the examples I
>> > think. The real question is are there any issues, because those are just
>> > WARNings. Did it break the test?
>> >
>> > John
>> >
>> > On Thu, Jul 12, 2012 at 11:30 PM, David Medinets
>> > <[hidden email]>wrote:
>> >
>> >> I did not expect one of the tests to be looking for the site
>> >> configuration file. When compiling Accumulo for the first time, this
>> >> configuration file can't exist ... can it?
>> >>
>> >> Running org.apache.accumulo.server.tabletserver.InMemoryMapTest
>> >> 12/07/13 01:56:09 WARN conf.SiteConfiguration: accumulo-site.xml not
>> >> found on classpath
>> >> 12/07/13 01:56:09 WARN util.NativeCodeLoader: Unable to load
>> >> native-hadoop library for your platform... using builtin-java classes
>> >> where applicable
>> >>
>>