[jira] [Updated] (ACCUMULO-131) ZookeeperInstance gets stuck when given bad host

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (ACCUMULO-131) ZookeeperInstance gets stuck when given bad host

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/ACCUMULO-131?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Keith Turner updated ACCUMULO-131:
----------------------------------

    Fix Version/s:     (was: 1.4.1)
                   1.4.2
   

> ZookeeperInstance gets stuck when given bad host
> ------------------------------------------------
>
>                 Key: ACCUMULO-131
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-131
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>            Reporter: Keith Turner
>            Assignee: Eric Newton
>             Fix For: 1.4.2
>
>
> Keith Massey reported the following issue on the mailing list.
> {quote}
> A user of our recently filed a bug with us because our code hung forever when she gave us an address for a zookeeper that was not running. I think I've traced the problem into org.apache.accumulo.core.zookeeper.ZooSession.connect(). If the connection to the zookeeper fails it throws a ConnectException, which gets caught by the catch (IOException) block, which logs the message and keeps trying infinitely. It's definitely user error passing in an invalid zookeeper. But shouldn't that method bail out after some time?
> Thanks.
> Keith
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira